[PEAK] access violation with py24/msvc compiler

Phillip J. Eby pje at telecommunity.com
Thu Jan 27 11:40:33 EST 2005

At 06:22 PM 1/27/05 +0200, alexander smishlajev wrote:
>i am trying to build PEAK for python2.4 with Microsoft Visual C++ Toolkit 
>2003, and i get access violation when i run test suite.  i have found that 
>access violation occurs at the time of peak.model.features import, i.e. it 
>is enough to do just
>   python -c "from peak.model import features"
>i have further narrowed the problem to class structField.  the body of 
>this class definition is processed fully, and then i get the error; next 
>statement is not executed.
>could you help me to track the problem down, please?

Have you tried stepping through it in a debugger?  E.g., put 
pdb.set_trace() in the body of that class and step through to find the 
exact point of failure.  I suspect it's something happening in the 
metaclass initialization, but if you're just using print statements or some 
such to see where it stops, you're not seeing the actual Python statement 
that's failing.

>the error does not occur if i build PEAK with mingw32 compiler.

Which is interesting, to say the least.  I personally build and test with 
mingw32, so I suppose it shouldn't be surprising that it works with 
that.  But the other way failing is rather curious to say the least.

More information about the PEAK mailing list