[TransWarp] RFC: DM SPI change

Ulrich Eck ueck at net-labs.de
Thu Jan 16 05:07:39 EST 2003

--On Mittwoch, 15. Januar 2003 20:32 -0500 "Phillip J. Eby" <pje at telecommunity.com> wrote:

> With all this discussion lately about peak.storage and DM's, I'd like to do a slight renaming of some DM methods.
> It's bothering me that data managers are inconsistent with other PEAK abstract base classes, in that the methods for
> overriding in a subclass don't start with '_', even though they are private and not intended to be called by users of
> the DM.  The 'save()', 'load()', 'ghost()', 'thunk()', etc. methods should all start with '_'.  I think this change
> should be made soon, so that there don't end up being too many DMs "in the wild" that will need to change for this.


Ulrich Eck
net-labs Systemhaus GmbH
Ebersberger Str. 46
85570 Markt Schwaben
fon:   +49-8121-4747-11
fax:   +49-8121-4747-77
email: ueck at net-labs.de

More information about the PEAK mailing list