[TransWarp] RFC: DM SPI change

Phillip J. Eby pje at telecommunity.com
Wed Jan 15 20:32:54 EST 2003

With all this discussion lately about peak.storage and DM's, I'd like to do 
a slight renaming of some DM methods.  It's bothering me that data managers 
are inconsistent with other PEAK abstract base classes, in that the methods 
for overriding in a subclass don't start with '_', even though they are 
private and not intended to be called by users of the DM.  The 'save()', 
'load()', 'ghost()', 'thunk()', etc. methods should all start with '_'.  I 
think this change should be made soon, so that there don't end up being too 
many DMs "in the wild" that will need to change for this.

Any objections?

More information about the PEAK mailing list