[TransWarp] Basic "storage jar" design

R. David Murray bitz at bitdance.com
Tue Jul 2 13:06:46 EDT 2002

On Sun, 30 Jun 2002, Phillip J. Eby wrote:
> If you have a strong opinion on what it should be, let's hear
> it.  :)  Right now, I'm torn between "jar" and "rack".  Rack is existing
> ZPatterns terminology that many know and love, and it does almost exactly
> the same thing.  Jar has both _p_jar and Monty Python "storage jars" going
> for it, although I could perhaps argue that '_p_jar' stands for
> "persistence: just a Rack" if I wanted to tip the balance in favor of Rack.  :)
> In short, I'm undecided.  Somebody convince me of a direction to take on
> the naming.  :)

I'd vote for Rack too.  I would visualize a jar as having a bunch
of pickles crammed into it willy nilly, and you can only stick
things in or take things out at the top.  Or empty or load it all
at one go, which is how I (rightly or wrongly, but because of the
visualization the name invoked) thought Zope pickle jars worked.

A rack, on the other hand, I visualize more as you described:
something you can hand a ticket to and get back a *particular*
object or initialized slot.


More information about the PEAK mailing list