[TransWarp] Basic "storage jar" design

Roché Compaan roche at upfrontsystems.co.za
Mon Jul 1 01:14:01 EDT 2002

> > > Anyway, final terminology can wait a bit, since there's no 
> code as yet.
> >
> >But let's not neglect it :)
> If you have a strong opinion on what it should be, let's hear 
> it.  :)  Right now, I'm torn between "jar" and "rack".  Rack is existing 
> ZPatterns terminology that many know and love, and it does almost exactly 
> the same thing.  Jar has both _p_jar and Monty Python "storage 
> jars" going 
> for it, although I could perhaps argue that '_p_jar' stands for 
> "persistence: just a Rack" if I wanted to tip the balance in 
> favor of Rack.  :)
> In short, I'm undecided.  Somebody convince me of a direction to take on 
> the naming.  :)

My vote goes for Rack.

I don't really have a strong opinion, but I can tell you what helped
me when I looked at Transwarp the first time:  Coming from ZPatterns,
recognizing a "Specialist" and instantaneously knowing what it does.
I immediately started looking for "Rack".  I didn't take me that long
to figure out that it has become something else, but I still had
to figure :)

Roché Compaan
Upfront Systems			http://www.upfrontsystems.co.za 

More information about the PEAK mailing list