[PEAK] Laziness, terminology, and the Trellis API

Phillip J. Eby pje at telecommunity.com
Sat Mar 29 13:07:21 EDT 2008

At 04:09 PM 3/27/2008 +0200, Sergey Schetinin wrote:
>Regarding the terminology, I think renaming 'transient_variable' to 
>'signal' would be great, so what was 'receiver' becomes 'signal', 
>'discrete'/'compute_transiently' could be 'emit', 'emitter', 
>'transmit'  or some variation on that.

Actually, the idea was that receiver would become 
'variable(resets_to=...)', and discrete would become 
'compute(resets_to=...)' or 'maintain(resets_to=...)'.

>Also, some way to recompute the rule only if there is a signal 
>present would be great as well. 'if self.signal is not None:' works, 
>but often seems unnecessary.

It's not unnecessary, in fact it's the best way to do it, as when the 
signal is false, it won't be subscribed to anything that's inside the if block.

>'resets_to' could be renamed to 'nosignal' as well, not much typing 
>saved, but mnemonically a much better choice IMO.

resets_to means that the thing in question *is* a signal, in your terminology.

More information about the PEAK mailing list