[PEAK] attempting to setup easy_install.

Israel C. Evans israel at uandmedance.com
Tue Oct 4 10:04:51 EDT 2005


I hope this is the proper mailing list for this issue. I was a little  
unsure of where to go for support for this particular module, but hoped  
that the parent PEAK list would be good. If it's not, I apologize.

I've recently been trying to install easy_install.py but have run into  
some strange issue that I can't quite figure out. After following the  
install directions on the Wiki  
I attempted to install TurboGears and I received and error, then I tried a  
few other packages and doing so gave me the same error everytime.  The  
error looks like this:

iz at elmlish:/usr/lib/python2.4/site-packages$ sudo easy_install.py -f  
http://www.turbogears.org/download/index.html --script-dir  
Traceback (most recent call last):
   File "/usr/local/bin/easy_install.py", line 4, in ?
     pkg_resources.run_script('setuptools==0.6a1', 'easy_install.py')
line 407, in run_script
     self.require(requires)[0].run_script(script_name, ns)
line 914, in run_script
     raise ResolutionError("No script named %r" % script_name)
pkg_resources.ResolutionError: No script named 'easy_install.py'

I'm calling easy_install.py and it's responding, going through setuptools  
and then it seems that setuptools can't find easy_install.py.  What might  
be causing this and how might I resolve it?

Thank you so much for any assistance you can offer.

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

More information about the PEAK mailing list