[PEAK] peak lanuch and freebsd

R. David Murray rdmurray at bitdance.com
Mon Nov 1 17:48:39 EST 2004

When I run peak lanuch on my machine (FreeBSD 5.2.1), the web browser
(w3m) hangs waiting for an answer.  If I run peak serve, figure
out the port number, and connect from another window, I can
see the page (I'm running the CGI demo for the moment).  Am
I doing something wrong?  I just did:

PYTHONPATH=/usr/local/src/PEAK/examples/trivial_cgi peak launch import:the_cgi.DemoCGI

When I ctl-C the command, the traceback looks like this:

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/wsgiref/handlers.py", line 93, in run
  File "/usr/local/lib/python2.4/site-packages/wsgiref/handlers.py", line 134, in finish_response
  File "/usr/local/lib/python2.4/site-packages/wsgiref/handlers.py", line 217, in write
  File "/usr/local/lib/python2.4/site-packages/wsgiref/handlers.py", line 273, in send_headers
  File "/usr/local/lib/python2.4/site-packages/wsgiref/handlers.py", line 198, in send_preamble
  File "/usr/local/lib/python2.4/socket.py", line 256, in write
  File "/usr/local/lib/python2.4/socket.py", line 243, in flush
error: (32, 'Broken pipe')

I have to ctl-C it a second time to get back to the prompt.

This reminds me of a problem I had with Zope unit tests several years ago,
but the details are really fuzzy.  That one was FreeBSD specific, I think,
which is why I mention the OS here....


More information about the PEAK mailing list