[PEAK] Upgrading required Python version

Phillip J. Eby pje at telecommunity.com
Wed Dec 22 01:32:08 EST 2004

At 04:40 PM 12/21/04 -0500, Ty Sarna wrote:
> > Hi all.  I'm thinking about bumping the version of Python required for
> > PyProtocols and PEAK.  Does anybody besides me actually still use
> > 2.2?  And, would anyone see a problem upgrading to 2.4?
>I'm +1 (for large values of 1) on dropping 2.2 support, and maybe +0.75
>on dropping 2.3. Personally I've mostly switched to 2.4 and would love
>to be able to start using the decorator syntax and such, as long as it
>isn't going to hurt anyone else.

Okay, so it looks like the consensus so far is:

* Nobody uses 2.2 but me
* Most people are okay with using 2.4, but a few might be mildly inconvenienced

Based on this, I'm thinking I'll go ahead and move to requiring 2.3 for 
PyProtocols 1.0 and PEAK CVS.  I think maybe I'll wait a little longer 
before requiring 2.4, just to give it some time to become more widely 

One minor issue with using 2.3 instead of 2.4 is the DOCTYPE parsing bug, 
that can show up as a failed PEAK unit test.  I'm not sure how to work 
around it exactly, because it's considered a Python bug and the behavior 
goes away again in 2.4 (and maybe 2.3.5 when it comes out).  So, that may 
take some investigation.

Anyway, I'm not taking any action on this today, and maybe not even this 
week/month/year; I just wanted to find out what everyone's status was.

More information about the PEAK mailing list