[TransWarp] Action Plan for the Eradication of Singletons
alex at ank-sia.com
Sun Apr 27 11:26:29 EDT 2003
Phillip J. Eby wrote:
> For right now, I'm going to go ahead and start coding with the name
> 'Application', but I'd like to hear some more input on the subject
> before finalizing the name. Some major contenders for the name are
> 'RootConfig' and 'ConfigRoot' -- they sound like the interface, and
> don't sound like you should subclass them. Maybe even
> 'config.RootComponent', although that sounds like maybe you would want
> to subclass it.
> Anyway... if you have thoughts on the name, please speak up.
for me, 'RootConfig' seems to be the best of four.
More information about the PEAK